Possible Login Issues
Incident Report for MPOWR Envision
Resolved
We have continued to monitor our authentication provider's solution since yesterday and it has remained stable. The root cause has been identified and they will also provide us with a detailed Root Cause Analysis that will better inform us of what happened along with the steps they are taking to ensure it doesn't happen again. We sincerely apologize to all affected customers and will post additional follow-ups here as we learn more.
Posted Apr 21, 2021 - 06:47 CDT
Monitoring
Our authentication provider has implemented a solution and is reporting that service has been restored. They are continuing to monitor performance and stability. We will continue to monitor and provide additional information as it becomes available. We thank you again for your patience.
Posted Apr 20, 2021 - 15:18 CDT
Identified
Our authentication provider has identified the issue, it is an all hands on deck situation with their entire engineering team working towards a solution.
Posted Apr 20, 2021 - 13:10 CDT
Update
Our authentication provider is continuing to work on this incident and doing everything they can to restore service. At this time, it is still unclear as to the root cause of the issue. We understand that this is causing a significant impact and we thank you for your patience.
Posted Apr 20, 2021 - 12:48 CDT
Investigating
Our systems have detected possible issues with our authentication provider. They are currently investigating, once they provide more information we will provide an update.
Posted Apr 20, 2021 - 11:42 CDT
This incident affected: Application (Authentication).